Factor/Requirements

Compiler version

The Factor VM is written in C++ and uses GNU extensions. Factor must be compiled with GCC 3.4 or later. When compiling with GCC 3.4, boost::unorderedmap must be installed. On GCC 4.x, Factor uses std::tr1::unorderedmap which is shipped as part of GCC.

x86 chips without SSE2

Factor binary packages require an x86 CPU with SSE2. If you build from source, Factor will only use SSE2 if its available. Expect much lower performance on floating point code if SSE2 is not available, since Factor does not generate optimized code for the obsolete x87 floating point unit.

Windows x86

Factor requires Windows XP, Vista, or 7.

To compile Factor from source on Windows, you must install a GNU toolchain, either Cygwin or Mingw. For details, see Setting up a Windows compilation environment.

Mac OS X

Factor requires Mac OS X 10.5 (Leopard) or 10.6 (Snow Leopard).

Linux

Factor requires a distribution with Linux kernel 2.6.

Factor will use X11 for the UI. For X11 support, you need development packages for X11, Pango, and OpenGL. On a Debian-derived Linux distribution (like Ubuntu), you can use the following line to grab everything:

sudo apt-get install libc6-dev libpango1.0-dev libx11-dev libgl1-mesa-dev

Note that if you are using a proprietary OpenGL driver, you should probably leave out the last package in the list.

FreeBSD, NetBSD, OpenBSD

Factor requires the following operating system versions:

  • FreeBSD 7
  • NetBSD 5
  • OpenBSD 4.5

This revision created on Fri, 9 Oct 2009 08:36:10 by slava